Corrigindo erros de permissão do WordPress

Wordpress utf8

Neste breve artigo vamos abordar  como corrigir erros de permissão do WordPress utilizando o sistema operacional Linux (Ubuntu/Debian).

Primeira coisa que você deve saber é jamais dê permissão 777, porque isso significar oferecer acesso total, qualquer usuário poderá mexer naquele diretório, ou seja se não quiser ficar vulnerável não use 777.

Editando arquivo wp-config.php

No diretório raiz da sua instalação do WordPress, abra o arquivo wp-config.php, nesse caso vamos usar o nano como editor.

No final do arquivo wp-config.php, inseria o código abaixo que irá criar uma constante:

Definindo permissão

Partindo do princípio que você tem permissão de sudo, execute os comandos abaixo na pasta raiz da sua instalação WordPress.

Vamos definir a permissão de dono para o usuário e grupo www-data.

Agora, defina a permissão 755 em todas as pastas.

E por fim, vamos definir a permissão 644 para todos os arquivos.

Dúvidas?

Você tem outras dúvidas? O tutorial não funcionou? Deixe seu feedback nos comentários abaixo. Bom, espero que essa dica tenha sido útil, temos também outro artigo sobre como converter UTF8MB4 para UTF8 no WordPress.